6

Adaptateur ethernet compatible pour Karotz

Comment faire pour connecter un Karotz en Ethernet plutôt qu’en WiFi ?

Simple, il suffit d’acheter l’adaptateur officiel ! Celui-ci est toutefois un peu cher et va devenir difficile à trouver. Pour ne pas se compliquer la vie il suffit d’acheter un dongle qui a le même chip contrôleur Ethernet ASIX MCS7830, reconnu par le noyau Linux du Karotz

Mon choix

J’ai acheté le LogiLink UA0025C qu’on trouve pour une quinzaine d’euros port compris sur amazon.fr ou une dizaine d’euros sur amazon.de.

Configuration

Etant sous OpenKarotz, pas besoin de repasser par la procédure complète de configuration avec clef USB et tout le tintouin :

On se connecte en telnet sur le rongeur (via le WiFi donc) et on vérifie que l’adaptateur est reconnu

# dmesg

...
MOSCHIP usb-ethernet driver 1-1.2:1.0: usb_probe_interface
MOSCHIP usb-ethernet driver 1-1.2:1.0: usb_probe_interface - got id
usb 1-1.2: applying rev.C fixup
usb 1-1.2: applying rev.C fixup
usb 1-1.2: manual set_interface for iface 0, alt 0
eth0: register 'MOSCHIP usb-ethernet driver' at usb-s3c24xx-1.2, MOSCHIP 7830/7730 usb-NET adapter, 00:60:6e:43:50:ec
drivers/usb/core/inode.c: creating file '003'
usb 1-1.2: New USB device found, idVendor=9710, idProduct=7830
usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.2: Product: UA0025C              
usb 1-1.2: Manufacturer: Moschip Semiconductor
usb 1-1.2: SerialNumber: 6e000001
...

Puis créer un fichier /etc/conf/ip_eth0.conf à partir du fichier de configuration  de l’interface WiFi

# cd /etc/conf
# cp  ip_wlan0.conf ip_eth0.conf
# vi ip_eth0.conf
{"cmd":"set_ip","dhcp":true,"interface":"eth0"}

Accéder à son Karotz

Voilà, il suffit de rebooter et de récupérer l’adresse IP affectée par son serveur DHCP pour pouvoir se reconnecter sur le lapin avec celle-ci. Attention, il vaut mieux savoir comment trouver cette information sur son serveur DHCP car l’interface WiFi n’a plus d’adresse IP et n’est plus accessible… Par contre la bonne nouvelle c’est qu’il suffit de débrancher l’adaptateur et de rebooter pour que le karotz se reconnecte en WiFi.

Astuce !

Si possible, affecter la même adresse IP aux interfaces WiFi et Ethernet. Avec un serveur DNS/DHCP dnsmasq, il est possible de le faire en suivant la procédure documentée ici :  Aide mémoire dnsmasq sur Debian. Ça permet d’utiliser une même URL pour accéder à OpenKarotz, sans se préoccuper de savoir si celui-ci s’est connecté en Ethernet ou en WiFi.

Références

6 Comments

  1. Bonjour,
    je viens d’acheter l’adaptateur logilink UA0025C, mais la connexion en ethernet du lapin ne fonctionne pas.
    J’ai lancé la commande dmesg mais j’ai l’impression qu’il y a une erreur:
    usb 1-1.3: new full speed USB device using s3c2410-ohci and address 3
    usb 1-1.3: default language 0x0409
    usb 1-1.3: uevent
    usb 1-1.3: usb_probe_device
    usb 1-1.3: configuration #1 chosen from 1 choice
    usb 1-1.3: adding 1-1.3:1.0 (config #1, interface 0)
    usb 1-1.3:1.0: uevent
    rt2500usb 1-1.3:1.0: usb_probe_interface
    rt2500usb 1-1.3:1.0: usb_probe_interface – got id
    phy0 -> rt2500usb_init_eeprom: Error – Invalid RT chipset detected.
    phy0 -> rt2x00lib_probe_dev: Error – Failed to allocate device.
    rt73usb 1-1.3:1.0: usb_probe_interface
    rt73usb 1-1.3:1.0: usb_probe_interface – got id

    Merci d’avance.

    • J’ai ces messages aussi, juste après ceux indiqués ci-dessus et la ligne hub 1-1:1.0: port 3, status 0101, change 0000, 12 Mb/s. C’est normal manifestement.

      1/ Est-ce que le lien monte bien au niveau 2 sur le switch ou le routeur (lumières clignotent au niveau du port du switch, mais pas sur l’adapteur logilink, en tout cas le mien) ?
      2/ Si oui voir sur le serveur DHCP s’il y a bien une requete venant du karotz et quelle adresse est attribuée. L’adresse MAC de l’adapteur Logilink commence par 00:60:6e (vendor code de DAVICOM SEMICONDUCTOR, INC.)

      Il faudrait re-vérifier le fichier de config :
      -bash-4.1# cd /etc/conf
      -bash-4.1# diff ip_wlan0.conf ip_eth0.conf
      --- ip_wlan0.conf
      +++ ip_eth0.conf
      @@ -1 +1 @@
      -{"cmd":"set_ip","dhcp":true,"interface":"wlan0"}
      \ No newline at end of file
      +{"cmd":"set_ip","dhcp":true,"interface":"eth0"}
      \ No newline at end of file

      ifconfig pour voir les config des interfaces réseau

  2. Bonjour,
    désolé de répondre que maintenant, j’étais en congés.
    Alors:
    1/ Le lapin est connecté en CPL… Lorsque je branche un PC sur le CPL, j’observe que les lumières du LAN sont OK. J’ai connecté le lapin direct sur la BOX sans CPL. Aucun voyant n’est allumé. Le lapin se connecte donc en WIFI.
    2/ Voici ce que j’exécute comme commande telnet

    -bash-4.1# cd /etc/conf
    -bash-4.1# diff ip_wlan0.conf ip_eth0.conf
    --- ip_wlan0.conf
    +++ ip_eth0.conf
    @@ -1 +1 @@
    -{"cmd":"set_ip","dhcp":true,"interface":"wlan0"}
    \ No newline at end of file
    +{"cmd":"set_ip","dhcp":true,"interface":"eth0"}
    \ No newline at end of file

    La commande ifconfig renvoie:
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:200 (200.0 B) TX bytes:200 (200.0 B)

    wlan0 Link encap:Ethernet HWaddr 00:0E:8E:2C:8E:57
    inet addr:192.168.1.98 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:188 errors:0 dropped:0 overruns:0 frame:0
    TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:13736 (13.4 KiB) TX bytes:11845 (11.5 KiB)

    wmaster0 Link encap:UNSPEC HWaddr 00-0E-8E-2C-8E-57-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    Cordialement,
    Romain

  3. BOnjour,
    j’ai l’impression que le karotz ne détecte pas l’adaptateur Ethernet…
    Cordialement,
    Romain

  4. Effectivement, on dirait qu’il ne le reconnait pas. Est-ce que si tu branches l’adaptateur tu as bien les messages indiqués ci-dessus quand tu tapes la commande dmesg ?
    Il faudrait tester l’adaptateur sur un PC pour voir s’il n’est pas défectueux

  5. Hello,
    Je rencontre exactement le même problème que Romain.
    Toujours avec l’adaptateur logilink UA0025C…

    J’ajouterai juste que je vois avec la commande demsg le message suivant:

    usb 1-1.2: new full speed USB device using s3c2410-ohci and address 3
    usb 1-1.2: default language 0x0409
    usb 1-1.2: uevent
    usb 1-1.2: usb_probe_device
    usb 1-1.2: configuration #1 chosen from 1 choice
    s3c2410-ohci s3c2410-ohci: urb c33a3bc0 path 1.2 ep0out 5f120000 cc 5 –> status -62
    usb 1-1.2: can’t set config #1, error -62
    drivers/usb/core/inode.c: creating file ‘003’
    usb 1-1.2: New USB device found, idVendor=9710, idProduct=7830
    usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    usb 1-1.2: Product: UA0025C
    usb 1-1.2: Manufacturer: Moschip Semiconductor
    usb 1-1.2: SerialNumber: 6e000001
    hub 1-1:1.0: port 3, status 0101, change 0000, 12 Mb/s
    usb 1-1.3: new full speed USB device using s3c2410-ohci and address 4
    usb 1-1.3: default language 0x0409
    usb 1-1.3: uevent
    usb 1-1.3: usb_probe_device
    usb 1-1.3: configuration #1 chosen from 1 choice
    usb 1-1.3: adding 1-1.3:1.0 (config #1, interface 0)
    usb 1-1.3:1.0: uevent
    rt2500usb 1-1.3:1.0: usb_probe_interface
    rt2500usb 1-1.3:1.0: usb_probe_interface – got id
    phy0 -> rt2500usb_init_eeprom: Error – Invalid RT chipset detected.
    phy0 -> rt2x00lib_probe_dev: Error – Failed to allocate device.

    Et donc pas de “eth0” en vue. Je pense que la ligne “usb 1-1.2: can’t set config #1, error -62” indique qu’il n’y a aucun id raccordé au port ethernet…

    Bref est-ce que, Romain, tu as pu finalement faire fonctionner ta connection ethernet? Si oui: comment tu as fait? Si non: est-ce que quelqu’un a une idée pour m’aider? Merci d’avance.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *